T-Com IPv6 test

My ISP runs an IPv6 test since the autumn of 2009. Now I write a post about my settings on my home Debian server/router which work correctly for me to use IPv6.

I have a script called /etc/network/if-up.d/adsl which starts the v4 PPPOE connection:

pppoe-start /etc/ppp/pppoe-ipv4.conf


pppoe-stop /etc/ppp/pppoe-ipv4.conf
pppoe-stop /etc/ppp/pppoe-ipv6.conf
killall -9 pppd
killall -9 pppoe
killall -9 pppoe-connect

/etc/ppp/ip-up.d/ipv6 starts the v6 connection, when the v4 connection is ready. This case ppp0 will always be the v4 interface and ppp1 will be the v6 interface.

pppoe-start /etc/ppp/pppoe-ipv6.conf

pppoe-ipv6.conf has the same settings as the ipv4 one except for one extra line: PPPD_EXTRA=”ipv6 ,”
Of course the IPv6 username is different, my original IPv4 PPP username is user@t-online.hu and the one has to be used for the IPv6 PPP line is user@ipv6.t-online.hu.

I have a script called /etc/ppp/ipv6-up.d/0initv6 which initializes everything related to the v6 connection. It can be downloaded here. Because my ISP changed the first 64 bits (I call it the “global part”) of my delegated IPv6 range once, I decided to make the script resistant to these changes. So the script creates the dhcp6s and radvd configs automatically. I turned off automatic start of dhcp6c, dhcp6s and radvd on system startup (I’ve deleted the symlinks from /etc/rc.x dirs). The ISP does not automatically give my server the IP address ::1, so the script takes care setting that using ifconfig for the interface also.

I need both dhcp6s and radvd for my Windows clients to use my server’s IPv6 connection. radvd announces the IPv6 connectivity to them and sets the default gateway, while dhcp6s gives them IPv6 addresses. The server only uses dhcp6c for obtaining the IPv6 address from the ISP, default gateway is set manually.

My dhcp6c.conf is here. The dhcp6s.conf.template is here. radvd.conf.template is here. My ip6tables config is here.

I hope these settings will help someone to connect to the IPv6 network.

fred 2014-08-24 16:51:50

Hi nonoo,
your Page convinced me in using a start/stop-Script to get my ipv6 working at home.
My Provider is very small but also seems to delegate a new ipv6-subnet at every reconnect.
I cant believe that it has to be done like this on linux (restarting these daemons after reconnect) – but hey – it works :D

Thank you very much for these Scripts !

Btw: The Link to the dhcp6s.conf.template is wrong- the /uploads/ is missing in the Url.


Nonoo 2014-08-24 18:44:09

Thanks, I’ve corrected the link!

Name (required)
E-mail (required - never shown publicly)
Webpage URL
You may use <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> in your comment.

Trackback responses to this post

About me

I'm Nonoo. This is my blog about music, sounds, filmmaking, amateur radio, computers, programming, electronics and other things I'm obsessed with. ... »


Listening now

My favorite artists